Power feed help

DANNYBOY

Registered
Registered
Joined
Nov 14, 2012
Messages
28
Not sure if this is the correct place for this, if not please let me know.

My power feed has no speed adjustment. It still runs but at full speed. Is this something that can be repaired, I or just get a new one.


Thanks Danny KIMG0077.JPG KIMG0078.JPG
 

Ulma Doctor

Infinitely Curious
H-M Platinum Supporter
Joined
Feb 2, 2013
Messages
1,294
off the top of my head it would appear that the potentiometer or the wiring in the potentiometer circuit is faulty.
there is the potential for control board failure too.
crack it open, inspect it and look for broken or burned wires or connections.
my unit didn't work when i got it on my BP.
turns out there was a broken wire inside, a 2 minute solder repair saved a couple hundred bucks ;)
 

kd4gij

Active User
Registered
Joined
Feb 7, 2011
Messages
4,931
Check the set screw that holds the speed knob on. I had one come loose and wasn't turning the shaft.
 

DANNYBOY

Registered
Registered
Joined
Nov 14, 2012
Messages
28
Awesome thanks pstemari, I honestly don't know why I didn't even think to Google a manual, That is usually the first thing I do. Haha brain fart I guess.

Thanks again
 
It can take up to an hour for ads to appear on the page. See our code implementation guide for more details. If you already have Auto ad code on your pages there's no need to replace it with this code
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock