Warco WM250V lead-screw height problem


May 7, 2017
Hi, this is my first post in this forum. I think I need some help and recommendations
Recently I was having some oil leakage from the Apron on my WM250V lathe and decided to try fix this.

I disassembled the leadscrew from the gearbox, detached the apron from the carriage and removed the entire Apron.
When having the Apron separated on the table I started to dissassembly it to it's separate components (e.g. removing gears and shafts), trying to see where the leaking oil originated from.

After almost everything was broken down, I found the issue:
Worn out O-ring on the shaft used for closing the half-nut.

After replacing the O-ring and reassembling everything It seems like the carriage is moving much too tight when close to the head-stock.
E.g. I find it very hard to turn the hand-wheel on the apron when coming close to the headstock.
All gears etc, move perfectly smooth when carriage is in the middle of the ways, and also when apron is not tightly screwed to the carriage (even close to the head-stock).
Also detaching the lead-screw from the gearbox shaft "solves" the tightness, so I've boiled down the problem to be related to the lead-screw being to far from the ways when close to the headstock (sub-mm distance)
However I have no clue what could have caused this to happen or how I should fix it.
The two removable pieces on the backside of the apron holding the half-nut and the power feed wormgear did have dual solid pins for ensuring correct placement, along with four bolts each. So I doubt I could have refitted these wrong, but...

Is there any way of adjusting the height of the leadscrew ends that I missed out on? Or do somebody have any idea of what could have gone wrong.
Attaching some pics from the procedure...







British Steel

Forum Guest
Register Today
First off, I'd determine whether it's the leadscrew/feedshaft that's off - do you have a V-block and a DTI with its mag stand? If so, fit the V-block to the front V way on the bed, mag on the stand and run the V-block and DTI along the leadscrew to see what deviation there is (horizontally and vertically) - if it's genuinely out you may have to remove and refit the gearbox, it'll give you a chance to remove the loose grinding and machining dust bonded with paint from the joint where it bolts to the bed...

If the leadscrew's not out of alignment, could the headstock end of the apron be out of alignment? that would give similar problems, trying to deflect the leadscrew through more and more of an angle and binding as it approached the gearbox?

Just my Ha'pennorth,
Dave H. (the other one)


May 4, 2015
That's a tuff thing to figure without seeing or being there , if there's anyway the parts on back can be flipped it may have been there. Or did a spacer or glib get forgotten? Any leftover parts , the bearing older at the tailstock could that have an internal adjustment or not be on right. Shooting in the dark here .


May 7, 2017
Hi, thanks for all good tips!
Sorry for not posting back earlier (It seems like my hobby machinist time is getting smaller and smaller, because of reasons).
I tried alot of things and finally I've solved it.
The block shown in 20170429_231459.jpg has two pins, seems like these was a little bit smaller in one end, which could allow for some play of this part until the screws got fitted. I've put them back the wrong way around, when refitting, Causing misalignment with the leadscrew, more noticable the closer the carriage got to the headstock... But then again, The only reason I can think of it not being tight close to the tailstock as well is that this part is closer to the headstock.

It can take up to an hour for ads to appear on the page. See our code implementation guide for more details. If you already have Auto ad code on your pages there's no need to replace it with this code
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock