[4]

Wells CNC Mill questions & request for assistance

[3]
[10] Like what you see?
Click here to donate to this forum and upgrade your account!

DHarris

H-M Supporter - Gold Member
H-M Supporter - Gold Member ($25)
Joined
Dec 1, 2016
Messages
164
Happy Father's day everyone.

I've also posted this request in the CNC sub-forum

Ok, I'm trying to help a friend get his "new" mill running. It's a Wells-Index mill 520/CEN/5 with a Centron M400 controller that was purchased at a government auction. When He first got the mill, the only message we got on the display was "clock c-mos battery low" but after replacing that chip on the cpu board (AR-B1564 - ACROSSER) but now the display is just blank.

With a choice of 3 main systems boards in the system (CPU, Display / keyboard control, and servo motor controller board) and not being sure if any of them are "good", I need a starting point to trouble shoot. I've checked all of the voltages / power supplies and connections. 3.5" floppy drive is working fine.

So, my question - Does anyone have one of the M400 control modules that you would be willing to install our CPU board into to see if it's at least running at all???

I live in Northern California (Sonoma county wine country).

Thanks for reading -
Dave Harris
 

DHarris

H-M Supporter - Gold Member
H-M Supporter - Gold Member ($25)
Joined
Dec 1, 2016
Messages
164
Sorry dlane - meant CNC - the flying fingers of doom don't always hit the right keys.

will try to get photos on Wed. when I'm there next.
 

Martin W

H-M Supporter - Gold Member
H-M Supporter - Gold Member ($25)
Joined
Mar 26, 2014
Messages
470
Hi Dave
There are lots of knowledgeable people here to help. Try posting on Practical Machinist also.
Have you tried contacting Wells Index? They may be able to help with error codes.
I worked on robot support years ago at John Deere for the welding robots. I know there, if we had trouble with any boards or processors we would just change them to get back up and running. I know that's not cost effective here.
Most times it was just a cold solder joint, or capacitor . Take a magnifying glass and scan for scorched solder joints or bulged capacitors.
Hope you have better advice from someone else. This is all I have offer.
Cheers
Martin
 
Last edited:

DHarris

H-M Supporter - Gold Member
H-M Supporter - Gold Member ($25)
Joined
Dec 1, 2016
Messages
164
Hi Martin,

Thanks for the reply. We've contacted Wells and they DO still support the Mill - - but they don't support the Centronix control module. Contacted Centronix and their reply is that the M400 controller is "too far out of date" so no direct support with (expensive from them even if they had them) replacement PCB's. They do have an upgrade solution for almost $7,000.00 but that's more than we want to spend at this time. Also, we want to keep the servo motors that are on the machine now so any other upgrade solutions will need to be compatible with them as well. We do have a line on a replacement board for the CPU at a reasonable price - we will see if that plays out.

Dave
 
[5] [7]
Top